Centos 6 安装python2.7.5

centos 是自带python的。但是版本稍微旧一些。搞python开发,肯定要用新一点的稳定版。所以,要升级一下python。

安装:

wget http://python.org/ftp/python/2.7.2/Python-2.7.2.tar.bz2

tar jxvf Python-2.7.2.tar.bz2
cd Python-2.7.2
./configure
make
make install

注意:

安装python之前,最好确认一下gcc是否安装。yum install -y gcc

否则./configure 阶段就会报错了

 

看版本号:

运行python,发现版本还是默认的,系统自带的2.6版本

 

更改系统默认的python:

建立软连接,使系统默认的python指向python2.7

正常情况下即使python2.7安装成功后,系统默认指向的python仍然是2.6版本,而yum是基于python2.6才能正常工作。所以要将系统默认的python指向到2.7版本。

/usr/local/bin/python2.7 -V

mv /usr/bin/python /usr/bin/python.bak

ln -s /usr/local/bin/python2.7 /usr/bin/python

运行一下python,或者:

python -V

修正yum报错:

如果打yum命令,你会发现报错了。提示你可能是python版本不对。所以我们要把yum依旧指向老的python2.6版本:

vi /usr/bin/yum

在打开的文件里的头一行,也就是指定python环境的那行代码,修改成:

#!/usr/bin/python2.6

坚持原创技术分享,您的支持将鼓励我继续创作!